#1 2020-09-13 11:23:24

From: South Africa
Registered: 2020-09-13
Posts: 1

My BIOS was 4 years out of date

or other sale or transfer of Clearwater’s assets
Posted on Tuesday September 08, 2020

Home Privacy Policy Privacy Policy Clearwater 2020-06-05T11:49:58-05:00 Privacy Policy. Effective on:  July 12, 2018 Purpose: This Privacy Policy (“Policy”) explains the personal information that Clearwater Compliance LLC (“Clearwater”, “Our,” “We,” or “Us”) collects from you, or that you may provide to us, through our websites, …

The post or other sale or transfer of Clearwater’s assets appeared first on betfair.

Clayton & McKervey is led by Rob Dutkiewicz
Posted on Tuesday September 08, 2020

How We Help Service Approach. Affiliations. Communications & Technology. Meet Our Team. Our Videos. Testimonials. Our Story. Home. About Us. Our Story. Over 60 years of dedication. our story & our goal. Our firm was founded in 1953 by Don Schmaltz and was called Schmaltz …

The post Clayton & McKervey is led by Rob Dutkiewicz appeared first on betfair.

17:15 Closing Panel
Posted on Tuesday September 08, 2020

Rikke Jansen. VR Artist and developer Rikke Jansen is an experienced games artist and technical artist, having been in the field for more than a decade. She discovered VR three years ago and saw the potential in the platform by discovering social VR. She’s been …

The post 17:15 Closing Panel appeared first on betfair.

Kayzerfish and most recently Kuti
Posted on Tuesday September 08, 2020

Ralf Hebecker. Hamburg University of Applied Sciences Since 2012, Ralf Hebecker has been Professor of Games Design and Production at the University of applied sciences Hamburg (HAW Hamburg), from 2006-10 he taught as lecturer for Interaction Design at Otago University in New Zealand . He is …

The post Kayzerfish and most recently Kuti appeared first on betfair.

10 novembre 2017 Tagged Achat
Posted on Wednesday September 09, 2020

Tag Archives: jeux mobiles. App Annie – Quelles catégories de jeux sont les plus populaires ? 9 septembre 2020 App Annie Rapport App Annie – Jeux mobiles : action stratégie, rapidité, argent, quelles. Tagged action, , , , , , argent, casino, core, , , …

The post 10 novembre 2017 Tagged Achat appeared first on betfair.

© Copyright Chaturbate.com 2011 – 2020
Posted on Wednesday September 09, 2020

CHATURBATE PRO. SIGN UP Lili_01”s Cam NEXT CAM (CTRL-/) ▸ Lili_01”s Bio and Free Webcam meow 254634 Oct. 1, 1997 22 Female Men, Women, Couples Russian Federation 1 week ago English, Russian Fit Hate cigarette”s smell Inks, septum Pics & Videos: 89 TOKENS OR FAN …

The post © Copyright Chaturbate.com 2011 – 2020 appeared first on betfair.

Sweet Arms – I Swear (TV Size) | Date A Live 3 Opening
Posted on Wednesday September 09, 2020

Log In. Log In. Most Viewed. 5 days ago 1510 views. 5 days ago 1496 views. 5 days ago 707 views. Sweet Arms – I Swear (TV Size) | Date A Live 3 Opening. 5 days ago 704 views. Kano – Nadamesukashi Negotiation [Uzaki-chan Wants …

The post Sweet Arms – I Swear (TV Size) | Date A Live 3 Opening appeared first on betfair.

Archie McPhee”s Shiitake Mushroom Candy Canes
Posted on Wednesday September 09, 2020

/ Rusty Blazenhoff / 4:30 am Tue Sep 8, 2020 Now there are candy canes flavored like shiitake mushrooms: “Thanks, 2020″. What”s brown and white and tastes nothing like Christmas. Archie McPhee”s Shiitake Mushroom Candy Canes, of course. Not sure what to do for the …

The post Archie McPhee”s Shiitake Mushroom Candy Canes appeared first on betfair.

Category: Hardware.

Noodlings | BIOS Games Serving the NDI™ Plugin

Another prime number… and no the title doesn’t make sense.
It’s just a nonsensical way to string everything together.
19th Noodling on a mid-August night.
18 Episodes… 18 is a fun number.
Divisible by 2, 3, 6 and 9.
The age you can vote in the  United States .
Fun facts  about  chocolate milk can be found here    BIOS Update Dell Latitude E6440 on Linux.
My BIOS was 4 years out of date.
I thought it was time to  update  it.
I went to the  Dell Support  page and noticed that they only had *.exe files available.
I sighed and was initially frustrated because my initial supposition was that I was going to have to have a working copy of Windows to do the update.     AntiMicro |  Map Keyboard  and Mouse Controls to Gamepad on openSUSE.
Installed a game called  Pokemon Insurgence  on Lutris and there was no way to play the game with a gamepad.
Rather than try to fight things, set out for an  application  that would map the keyboard controls to the WiiU Pro Controller that has become my gamepad of choice.
CPU Downgrade.
After receiving this message following a BIOS upgrade, I was forced to purchase a lower powered CPU for my AMD  Workstation .
OBS  NDI™ Plugin  on openSUSE.
The NDI plugin offers a fairly easy way to send OBS video signal (presumably other  application s can take advantage of this too) to another OBS instance on another machine.
This can come in handy for numerous reasons such as splitting up workloads between machines by capturing output from one machine, such as gaming computer, to stream with a dedicated unit that interfaces with YouTube.
BDLL Followup.
What have you done that would cause you to lose your Linux card        New Prototype Builds Bringing Leap, SLE Closer Will be Available Soon.
The release manager for openSUSE Leap, Lubos Kocman, has updated openSUSE’s develop community on efforts to bring the codes of Leap and SUSE Linux Enterprise closer together.
20200805 Stable 99MozillaThunderbird (68.10.0 -> 68.11.0)Several CVEs addressed.
transactional-update (2.22 -> 2.23)Subpackages: transactional-update-zypp-config.
Version 2.23.
Add “run” command to be able to execute a single command in a new snapshot.
Add “–drop-if-no-change” option to discard snapshots if no changes were performed (BETA, required for Salt integration).
Removed previous CaaSP Salt support (gh#openSUSE/transactional-update#33).
Avoid “file not found” message on systems without /var subvol.
20200806 Stable 99mariadb.
xen (4.13.1_04 -> 4.14.0_02).
20200807 pending Stable 99urlscan (0.9.4 -> 0.9.5).
20200810 Score of a moderate 84epiphany (3.36.3 -> 3.36.4).
gcc10 (10.2.1+git465 -> 10.2.1+git501).
gnome-mines (3.36.0 -> 3.36.1).
kernel-source (5.7.11 -> 5.8.0).
zypper-lifecycle-plugin (0.6.1490613702.a925823 -> 0.6.1596796104.87bdab7).
https://review.tumbleweed.boombatower.com/        Computer Chronicles – Fifth Generation Computers (1984).
The pioneers in the field talk about 5th generation computers capable of Artificial Intelligence and heuristic learning; giving computers context.
In 1984, computers were already being used to make knowledge based decisions.
The Computer Chronicles – Fifth Generation Computers (1984)        Take some time to have fun.
Good, clean wholesome fun.
Go for a walk, enjoy the weather on any day that it is possible.
Take some time to cherish each moment, whether it is good or bad, find the positive in the situation and make it a point to say “thank you” as often as possible.
AMD, , , , Dell, Gaming, Hardware, , , , , ,          Leave a comment          12 August 202013 August 2020                             AntiMicro | Map Keyboard and Mouse Controls to Gamepad on openSUSE.
Installed a game called Pokemon Insurgence on Lutris and there was no way to play the game with a gamepad.
Rather than try to fight things, set out for an application that would map the keyboard controls to the WiiU Pro Controller that has become my gamepad of choice.
I know I heard it was possible on a podcast some time ago and since I was probably doing something else and didn’t have a notebook handy to write down whatever it was, I began my search and found this AntiMicro as a solution.
A quick note, this is not a comprehensive and exhaustive analysis of all of its features.
I am covering just a portion of the features.

AntiMicro is in the official repositories for both Leap and Tumbleweed

To do the graphical click method, navigate here:    https://software.opensuse.org/package/antimicro    Alternatively, you can install it through the more exciting and personally gratifying method of the terminal:    sudo zypper install antimicro    For other distributions, search “antimicro” in your favorite software management system.
The Problem Game.
The game I wanted to set up to use a controller is Pokémon Insurgence.
I observed my oldest child watching a play through on the YouTube and he spoke of interest in the game.
I found the game on the Lutris site with an easy installation process.
The game I wanted to set up to use a controller is Pokémon Insurgence.
I observed my oldest child watching a play through on the YouTube and he spoke of interest in the game.
I found the game on the Lutris site with an easy installation process.
https://lutris.net/games/pokemon-insurgence/             The issue is, there was no way to have this game use any control pad.
Only the keyboard.
I thought this annoying and didn’t play the game… until AntiMicro, that is.
The configuration of AntiMicro is incredibly straight forward.
So much so that this little write-up is almost unnecessary but I thought I would share my experience anyway.
When the application starts up and the system is absent any controllers, you will be presented with this screen.
What is pretty fantastic is that when you do activate, or plug in a controller, there isn’t any fiddling required.
The application immediately reacts and presents some straight forward options.
I turned on my Wii U Pro Controller, my controller of choice on those periodic cases that I decide to play a game.
The application immediately presented options.
At this point, you can push buttons on the controller and identify the buttons and in this process, I did discover that the A and B are swapped as well as the X and Y.
I looked at the Controller Mapping configuration and it looks like the physical locations are correct but the labels seem to be incorrect.
I would call this a small papercut issue but it is indeed an issue.
So beware of the labels and make sure that the button and the action are correct.
It is best to verify.
I took some screen shots of the input configuration portion of Pokémon Insurgence so I could map the keys out.
For the arrow key configuration, you can very easily map it all onto the DPad and the joystick of your choice.
I set both to control the movement of the character.
There is, kindly, a present drop-down to make this selection.
Each of the other keys can be assigned but do take note that you assign the correct key to the correct button and verify labels.
When you select the button, you can then select the corresponding key.
Not relevant for this game but just to make note, you can also map mouse movements which, I see as being valuable if you want to configure a controller to manage mouse movements without using the Steam to do so.
After completing and subsequently tweaking my button selection.
I was able to play a solid 10 minutes of Pokémon Insurgence on my Linux machine quite happily.
At this rate, I might get through it in the next 6 years or so.
What I Like.
The configuration is splendidly simple to set up.
It is very intuitive and does as you would expect.
I appreciate how easy it is to set up and get going with it.
The on screen information about what you are doing is very appreciated.
Rather than digging through help or readme files, the important information presents itself.
Finally, this is a Qt application so it integrates nicely into Plasma and my dark theme looks great.
It is as though the interface was tested against Breeze dark as there were not any unreadable bits to the application.
What I Don’t Like.
The one little papercut of the reversal of some buttons is unfortunate but not a deal breaker.
It’s only important if you actually read the buttons and not go by the action flash.
The mouse controls isn’t exactly as I was hoping.
The movement of the cursor didn’t exactly have the variable movements I was expecting but there are so many options, there is, perhaps one that would give a kind of gradient movement.
So, this is not really a knock on the application as the default is probably best for most users.
I would say, this is a knock on me for not being satisfied with what is likely a sane default.
AntiMicro is a fantastic application, especially if you play old DOS games or other emulated games that don’t have adequate controller support.
This also has the bonus feature of being able to easily map your controller to act as a mouse which may be a nice addition to a media set-top box for the living room.
I am glad I stumbled on this and I wish I could give attribution to where I recently heard about it but seeing as I don’t recall, I will miss the opportunity to link to that source.
If I do find this I will add an edit.
If you have some games that don’t play nice with controllers, try AntiMicro, it just may give that old game a fresh coat of paint.
, Hardware, , , Qt         2 Comments          10 August 2020          4 Minutes                    BIOS Update Dell Latitude E6440 on Linux.
…Sort of.
It didn’t require using Windows.
My BIOS was 4 years out of date.
I thought it was time to update it.
I went to the Dell Support page and noticed that they only had *.exe files available.
I sighed and was initially frustrated because my initial supposition was that I was going to have to have a working copy of Windows to do the update.
My last Dell Latitude, a D630, the BIOS updates required a lot of fiddling on my part.
At the time, I would burn a special FreeDOS CD with the BIOS update EXE on it.
I figured I would have to do the same with this computer.
The good news is, that is not the case and it could be I am the last person to know this bit of information.
I am not sure how well known this process is, but the good news is, .

You don’t need Windows to do the BIOS update

Where I went to get the BIOS is here:    https://www.dell.com/support/home/en-us/product-support/product/latitude-e6440-laptop/drivers    I searched for “BIOS”         After a bit of searching, I found this page at Dell.com that explains how to update the BIOS on Linux or Ubuntu systems.
https://www.dell.com/support/article/en-us/sln171755/update-the-dell-bios-in-a-linux-or-ubuntu-environment    In short, the way to do this is to take the downloaded BIOS update.
EXE and put it onto a FAT32 formatted USB Drive.
It is quite important that you use FAT32.
An easy way to check is to use Gnome Disks, Gparted or KDE Partition Manager to verify.
Once verified that you are indeed using FAT32, copy the BIOS update.
EXE to the USB Drive.
Reboot the computer and one the Vendor image appears, press F12 for the One-time boot menu.
Then select BIOS Flash Update.
The flash update tool is a simple GUI.
Select the button to the top right with an ellipsis.
Next, you will be presented with a file dialog GUI where you can navigate to the USB drive.
Ensure you select the correct file and follow the prompts.
If you do not see the file, .

Select the drop-down tool adjacent File System:        Select the appropriate BIOS

EXE then OK         Next select Begin Flash Update.
The big warning is to keep your computer plugged into the “mains” and do not interrupt the process as it could possibly “brick” your system.
The process takes a few minutes to complete and the computer will automatically reboot.
Assuming it all goes well, you really shouldn’t notice a difference as the issues being fixed are under the surface.
Just to check, that the BIOS is indeed now updated.
I ran this in terminal:    > sudo dmidecode --type 0     Then you will get the resulting output.
# dmidecode 3.2Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.
Handle 0x0000, DMI type 0, 24 bytesBIOS Information       Vendor: Dell Inc.       Version: A24       Release Date: 06/13/2019       Address: 0xF0000       Runtime Size: 64 kB       ROM Size: 12288 kB       Characteristics:               PCI is supported               PNP is supported               BIOS is upgradeable               BIOS shadowing is allowed               Boot from CD is supported               Selectable boot is supported               EDD is supported               5.25"/1.2 MB floppy services are supported (int 13h)               3.5"/720 kB floppy services are supported (int 13h)               3.5"/2.88 MB floppy services are supported (int 13h)               Print screen service is supported (int 5h)               8042 keyboard services are supported (int 9h)               Serial services are supported (int 14h)               Printer services are supported (int 17h)               ACPI is supported               USB legacy is supported               Smart battery is supported               BIOS boot specification is supported               Function key-initiated network boot is supported               Targeted content distribution is supported               UEFI is supported       BIOS Revision: 65.24    I was just glad to see that 5.25″ floppy service is still supported.
Just in case it comes up, I can still utilize it.
Due to my laziness and inhibition to use Windows caused me to avoid pursuing updating my BIOS.
Dell, on newer systems (~2015 and later), have built in a service to perform these updates outside of the operating system and has removed or eliminated your excuses for keeping your system up to date and more secure.
I am glad I took the time today to figure this out and do the proper thing in keeping my system updated.
https://www.dell.com/support/article/en-us/sln171755/update-the-dell-bios-in-a-linux-or-ubuntu-environmenthttps://www.dell.com/support/home/en-us/product-support/product/latitude-e6440-laptop/driversPlaying in the terminal | dmidecode.
Dell, Hardware, ,          2 Comments          9 August 2020                             LG 29″ UltraWide | Monitor Upgrade and Configuration on Linux.
I have historically made my hardware decisions based on price, generally I get what I can get for  as low or as reasonable as possible.
Basically, I go for free or near-free and fabri-cobble something together.
After seeing some other computer setups, I have really thought that I want to be able to function more effectively and efficiently than I had been.
One of the areas that I have been less than happy has been my monitor layout.
I have been pushing 3 displays with my Dell Latitude E6440 and for the most part, it has been meeting my needs but there were some work flows that have not been working out so well.
What I had before was a kind of ah-hoc solution.
I started with one monitor than wanted more screen real estate so I placed it off to one side because that is just what made sense at the time.
What I had here was a laptop screen with 1920×1080 (FDH) resolution.
A monitor directly above with a resolution of 1440×900 (WXGA+) and off to the  top right a screen with the resolution of 1280×1024 (SXGA).
Both of those monitors I purchased for $10 each from a company upgrading everything.
I was pretty happy as going from one monitor to a second was fantastic and adding a third made it even better.
The problem I ran into was that the monitor above was not Full HD and sometimes it made for some usability issues with certain applications.
That was compounded by having a monitor to the right with a physically slightly taller display but pixel wise, quite a bit taller and it just made things weird when moving from monitor to monitor.
The solution presented to me by my e-friend, Mauro Gaspari is ultimately what I started to pursue  when he sent me a picture of his screen setup on Telegram.
What he had (probably still has) is a 1440p monitor.
I had never seen such a thing, it was so clean and made so much sense, especially with the ability to tile windows.
So, began my search and measuring to see what was feasable.
Fast forward to about eight months later, I purchased the LG 29WK50S-P.
This is a 2560×1080, 29″ with a 60Hz refresh rate.
Initially I wanted to go with a 3440×1440 (WQHD) screen but I couldn’t get one at the size and price I wanted.
Since I don’t have a whole lot of space and the distance it will be away from my face, any bigger than 29″ diagonal would take up too much space.
I also didn’t want to spend a whole lot so what I payed was $179.10 for this monitor and I am quite happy with the price.
Sure, more than the $10 I spent on the last monitor but a heck of a lot more pixels.
The description of this this monitor is a 29 Inch Class 21:9 UltraWide® Full HD IPS LED Monitor with AMD FreeSync.
It has the following features    AMD FreeSync™ Technology.
Dynamic Action Sync.
Black Stabilizer.
OnScreen Control.
Smart Energy Saving.
Screen Split to give you different picture choices with the monitor.
None of these features were all that important to me.
What I was most concerned about was the resolution and VESA mount.
The split screen feature, to which I mostly don’t care about, is intriguing as I could use the second display input and do some testing on other distributions with another computer.
I really wasn’t asking for much in a monitor, really.
I am going to take advantage of the AMD FreeSync at this time either but it is nice to know it’s there.
Initial Setup.
I have been spoiled in openSUSE Linux for years and years.
I haven’t really had to fiddle with anything to get my computer to use hardware.
I expected this ultra-wide monitor to be just as un-fiddly but it wasn’t.
For whatever reason.
The display didn’t recognize to computer its proper resolution.
I don’t know why if it is because it falls under the “other” resolution category or if there is some other issue.
I am running Tumbleweed so I do have the latest drivers and since this monitor has been around for a while, I wasn’t expecting any issues.
The Plasma Display Settings didn’t give me the option of 2560×1080 at all, a quick DuckDuckGo search which brought me to the solution to my troubles here on the openSUSE forum.
I started out by using some “old school” xrandr commands.
First I started out by defining a new mode:    xrandr --newmode "2560x1080_60.00"  230.76  2560 2728 3000 3440  1080 1081 1084 1118  -HSync +Vsync    Then I added a mode to the specific output.
xrandr --addmode HDMI-3 2560x1080_60.00    Then I sent the command to change the mode of the screen    xrandr --output HDMI-3 --mode 2560x1080_60.00    This worked but it is not a permanent solution as the next time I were to reboot, I would lose these settings.
That made it time to do an Xorg configuration file for this monitor.
Thankfully, it is just one simple text document.
Permanent Solution.
Using the handy dandy terminal, once again, I navigated to the appropriate folder    cd /etc/X11/xorg.conf.d/    Then instead of creating a standard type of file that could be overwritten like “50-monitor.conf“, I created a custom one for this particular monitor.
sudo nano 49-LG29WK50S.conf        There is not much in this configuration file, just the modeline and preferred mode along with the Identifier of HDMI-3:    Section "Monitor"   Identifier "HDMI-3"   Modeline "2560x1080_60.00"  230.76  2560 2728 3000 3440  1080 1081 1084 1118  -HSync +Vsync   Option "PreferredMode" "2560x1080_60.00"EndSection    This allowed for the Plasma Display module to now have the proper mode available in the drop down and for me to do arrange the screen properly.
And now doing something like video editing feels a lot cleaner and the width only makes this task so much nicer to accomplish.
It’s not a perfect setup but it is a more perfect setup than what I had.
What is nice is that I can very easily tile windows and jump to different applications without playing the, “where did I go” game.
I don’t know if I have any games yet that take advantage of the ultra-wide screen layout but from a productivity standpoint, this is fantastic.
I have been using it as the monitor with which I do CAD and I do like the wider display much better as the side menus are never in the way of the model itself.
Also, the extended design history is almost entirely seen on larger models too.
Although the DPI is not the same between the laptop and the ultra-wide, I am happy with it.
I don’t even know if I would want this monitor smaller or if maybe it is time to go up to a 15″ laptops screen.
That would make the DPI closer to being the same between the laptop and the monitor.
I am happy with it after one day of usage and over time, I am sure I will find irritations with the setup.
I want to note that I didn’t go for the curved screen.
I don’t think I am quite ready for such a “radical” idea of having a screen curved towards me.
Would it have been better.
Maybe, I can’t really say and maybe the next screen I purchase will be curved so that I can compare.
The way I see it, going from 16:9 resolution to 64:27 (21:9) was enough of a jump.
Adding another bit of unfamiliarity of a curve in the display might have just thrown me off (insert smile emoji).
I have more “testing” to do with the monitor but for the $179.10 I spent on it, I think it was worth it.
The contrast is nice, the brightness is nice, everything is very pleasing.
This might very well be one of the best technology purchases I have made.
I much prefer this to the ad-hoc, fabri-cobbled setup I previously had.
Ultrawide Monitor Help on the openSUSE ForumLG 29WK50S-P Ultrawide LED Monitor product pageDisplay Resolutions on Wikipedia.
Graphics, Hardware, , , ,          1 Comment          1 August 20201 August 2020          5 Minutes                    MechBoard64 | Replacement Commodore 64 Keyboard.
It happened again, unfettered access to the Internet has yielded yet another romp down the bunny trail to places that I don’t have time in which to go.
I have previously discovery of the Ultimate 64, a modern replacement board for the Commodore 64, now I have come upon another amazing bit of tech.
A modern replacement keyboard for the Commodore 64, the MechBoard64.
Every day, when I walk back to my “healing bench,” the place I fix my kids toys or things I break around the house, I see my extra, empty bread-bin box Commodore 64 shell.
It has been sitting empty since sometime in the early 90s and my mind will wonder to a place where that would be a functional computer once again.
Not that I need another Commodore 64, but I am thinking, often, I would like to have a modern re-implementation of the Commodore 64, specifically, with that Ultimate 64.

When I play games or do IRC with the Commodore 64

I am periodically reminded that old hardware can have some unwelcome hiccups and remind me why we moved beyond the 8-bit era.
Some behaviors of it are just not very welcome.
Glitching out, occasional crashing after hours of usage, lack of complete drive compatibility with the SD2IEC device and so forth.
I would like to have the best of both worlds, 8-bit fun and charm along with the modern conveniences of storage and reliability.
Is that too much to ask.
Keyboard Features.
I am not a huge proponent of the whole microswtich / mechanical keyboard craze, however, in the case of a Commodore 64, I think I very much indeed am interested in such.
The MechBoard64 has microswitches from Gateron fitted on a black PCB and mounted in laser cut aluminum brackets.
The aesthetic quality of the craftsmanship of that aluminum bracket with those microswitches affixed to the top has me gazing at it, very much desiring to posses such a carefully engineered labor of love.
I must admit, it is a beautiful looking piece of hardware and everything about it makes me want to build a re-implemented Commodore 64 to enjoy the reliability of the new hardware along with the charm and fun of the 8-bit era.
The Plan    I have priced none of this out, but I am intending on taking that old case of mine,        .

An Ultimate 64 and a new MechBoard64 keyboard to have a premium Commodore 64 experience

I would be short a user port but I am willing to bet I can do something more with those USB ports.
I am going to pause and day dream of the possibilities…        Since life has yielded me some extra time to think and do things, the time is right to go forth and make my childhood and adult fantasies coalesce into something I can use day-in and day-out.
Nothing against the original hardware but the reliability concerns have made it less fun to share with the next generation of technical enthusiasts.
I realize it is not exactly the same, but using the 37 year old hardware regularly does put it at risk of a fatal end.
I can’t help but come to the conclusion that I should protect it and keep it from the harmful effects of its usage.
This is going to be a fun project, not yet, but soon.
A re-implemented Commodore 64 with modern technology sounds like a winning proposition for those retro-computing compulsions.
New, yet not, familiar, yet not.
How fun.
https://www.breadbox64.com/blog/the-mechboard64/Ultimate 64 | A New Commodore 64 main board.
Commodore 64, Hardware         3 Comments          14 July 202013 July 2020                             A new Amiga 1200 Case and Keys in 2020.
I love my retro tech.
Old computers are just great things.

I moved to the Amiga after the Commodore 64 in the early 1990s

I stumbled upon this site and now I want to turn to my aging Amiga 1200 and black it out.
https://www.a1200.net/    So, why would I want to do this to my Amiga 1200.
Well, my old case is yellowing and so are the keys.
The keys and I have never really liked that biscuit and gray look.
When I saw the Amiga CDTV with its black keyboard and case, I thought how cool and sleek it looked but I wanted a more traditional computer (at that time) not something that was meant to go on your Hi-Fi stack.
Now, today, you can have both the cool black look along with the full fledged Amiga Computer.
What a great time to be an Amiga 1200 owner.
Things I only dreamed of, some 25 years ago are now availale today.
There are a lot of colors from which to choose.
Many more options than just black but I am not sure why anyone would want any other color than black.
The color computers are supposed to be.
Regardless of these color variations falling far outside of my preference, they do look pretty cool.
At the time of writing your options are the original white it called “Escom”, black, light grey, grey, pink, light blue, dark blue, orange, rubine red, violet, purple and translucent.
Link to Gallery of Amiga 1200 cases    I would personally go with black or dark grey for the cool factor.
Outside of wanting a different color of case, if you were anything like me, your computer was opened up with some kind of frequency and being an uncoordinated young teen, your case may be damaged from insertion and removal of the screws or breaking the plastic clips along the back by opening it up in the non-recommended fashion.
These new cases have screw brass inserts in all 6 screw towers.
So, unless you ‘Magilla Gorilla’ those fasteners, you are not likely to have issues.
Also, it’s all screws that hold the case together, no more clips to break.
I understand why Commodore did the clips, screws cost money and also add complexity into the manufacturing.
They were always looking to pinch a penny.
Brass inserts in screw towers     The bottom trapdoor, instead of being a slab of plastic now offers better cooling with extra vents.
The rear trap door (that I never used) has 3 options: The Plain door, like you would have had on your original A1200; a VGA hole for VGA out; and a DVI hole.
No HDMI, but I’m good with that.
I’m sure that can easily be remedied.
Rear trap door options     If you don’t have an actual Amiga 1200 motherboard to put in this, that is NOT a problem as this supports more than just the original board.
Smartly, you can use a Raspberry Pi, MiST FPGA, Keyrah V2 keyboard adapter, RapidRoad DoubleUSB and Lotharek HxC Floppy emulator.
So essentially pair this with an original keyboard or a new mechanical keyboard designed to fix this case and you are off to the races.
Since my keyboard is in good shape, I haven’t ever spilled anything on it or eat Cheetos while playing games as a young teen, I am looking to replace the keycaps.
It should also be noted that the new mechanical keyboard isn’t ready for purchase yet.
The look of these keys are great.
Black and dark grey looks absolutely fantastic.
My keyboard has the UK layout so this would fit perfectly.
I am pretty excited about having access to new things for old hardware.
What an exciting time to be into Retro Hardware.
I hope that this is a successful venture.
In order to buy a case, you will have to go to one of the partner site.
This is a great time to be a nerd into 1990s or earlier tech.
I have explored a lot of the Commodore 64 side of things and I think it’s time to play in the Amiga sphere a bit now.
https://www.a1200.net/Commodore 64 references on CubicleNate.com.
, Hardware, Upgrade         3 Comments          25 June 202026 June 2020                             APC Smart-UPS 1500 Battery Replacement.
I am of the opinion, if you plan to have a desktop computer, and by that I mean a machine without a built in battery, .

You need to have a UPS or Uninterruptible Power Supply

I am of the belief, go as large as you can reasonably afford.
Should you have a power interruption, your computer and equipment will thank you in the best way it knows how, by not turning off unexpectedly and corrupting your data.
I Received this used, APC Smart-UPS 1500 a few years back.
They did work when I got them, not for long as the batteries failed.
After building my workstation / server / desktop unit that I make do things all the time.
I decided, after a power outage, it was time to investigate the failure and fix it.
I was 99% sure that the batteries were dead as it was the “Replace Battery” light that was on.
Video montage of repair.
It’s not very good…    Disassembly.
Like in any repair of mine, I find that disassembling it first is the best way to go about it.
I have had countless other projects that have gone wrong because I trusted online documentation and batteries for a UPS are never cheap.
The first objective is to open it up.
The tools required for this was just a crossed-recess (Phillips) screw driver.
I opted for the battery operated driver because I am lazy.
Two screws on the front hold the battery compartment door shut.
After removing the batteries, I was completely certain that they were dead as the multi-meter made that very clear.
Search for Batteries.
My initial search for batteries lead me to realize that this was not going to be a cheap repair.
My local supplier of batteries had them listed at $54.00 each.
Others I found all were comparably as expensive.
Then I stumbled upon a site called BatterySharks.com that had these batteries for sale $48.00… for a pair.
For a pair.
I double checked the specs from the old batteries to the new batteries and I completed the order.
I can’t guarantee that the prices will stay so low but was certainly a fantastic deal.
Shipping wasn’t too bad, another $24.59 which brought the grand total to $72.55.
I was thinking, however, I am making a $72 gamble that there isn’t anything else wrong with this UPS.
It didn’t take long for the batteries to arrive.
The rather weighty package landing with a thud on my front porch signaled it had arrived.
The actual installation was really quite simple.
Just a reversal of disassembly.
Installing the terminal connections, reinstalling the protective terminal caps, I used a little double sided sticky tape to hold them together like the originals (and thinking about it, totally unnecessary), and screwed it back together.
Extremely basic.
I did clean up the corrosion with white vinegar just to be sure that there wouldn’t be any issues from the old battery acid that leaked.
After assembling it, it was time to do the initial “smoke test” to make sure that I didn’t mess anything up.
Sure enough, I turned it on and an incredibly uneventful yet thrilling beep followed that meant, all was well and ready to be used.
I did want to do some testing.
This included using a laptop hooked up to see that when the grid power was removed from the UPS, that it would continue kicking out uninterrupted power.
Upon removal of the power, a clunk with a 60 hz hum sound coupled with an alarming “beep” to signal the loss of power and sure enough, just like its name, the power to my computer was uninterrupted.
I let it sit a while so I could watch to see the battery charge meter climb while it remained plugged into the mains.
Since it all seemingly worked well so I shut down my server, router/firewall, access point and switch to plug it into the UPS.
The load indicator was fluctuating between 1 and 3 bars out of 5 while I was standing there and monitoring it for a while.
That was good news as it is well within the limits of this newly repaired but well aged device.
Power Loss.
Within a week of installing this newly finished UPS system, the power went out at my house.
The server, and network equipment kept chugging along and the battery charge held surprisingly well.
Since I was using my laptop, I could still access all things on the server, wirelessly, though I was unsure as to how long it would hold out.
After about 40 minutes or so, I thought I should probably start shutting things down nicely.
I checked the display and I still had plenty of battery to go so I left it and within 20 minutes of that, the power was restored.
The timing of this repair couldn’t have been better…        This was one of those projects that was well worth the time and effort.
I do know that I can connect  this UPS up to a computer and have it do things but I really am not sure what.
I think I need to start playing with the power awareness features so I can figure out how to safely shut down my server and Firewall safely should power levels get low.
Buying a new UPS can be quite expensive.
Repairing a used one is much more affordable and also, a better choice for reducing e-waste.
Hopefully, this little writeup and crap-tastic video will give someone just enough courage to try it out themselves.
https://www.batterysharks.com/APC-RBC7-p/APC-RBC7_ups12-18_x2.htmAPC.com UPS manufacturer website.
Hardware, Repair         5 Comments          8 June 20208 June 2020          4 Minutes                    Solaar | Application for Logitech Unifying Receivers and Devices on openSUSE.
I recently purchased a new Logitech wireless keyboard for my kitchen computer because the Bluetooth keyboard I previously used was driving me nuts.
Mostly for the keyboard layout and sometimes because it didn’t want to connect.
Possibly due to hardware failure or bad design.
It also doesn’t have media keys so I thought it best just to replace it.
I have previously used ltunify with success but I only used it because “L” comes before “S” so that was my first stop.
Since I received feedback that I should try Solaar I did so this time.

Since there isn’t an official Linux based application available from Logitech

the fine open source community has stepped in to make managing your devices simple and straight forward.
Since this application is in the Official Repository for Tumbleweed and Leap you can use graphical direct installation method or the more fun terminal way.
sudo zypper install solaar    YaST Software is also an option too.
Once it is installed, launch it using your preferred method, the menu, Krunner, etc.
Application Usage.
Right off the cuff, this is a more user friendly application with some additional features.
For starters, whatever devices you have connected to your Logitec receiver will display a battery status.
In this case below.
I have a keyboard and mouse already paired with the Unifying receiver.
Logical layout of the device listing, and verbose device information, device options and battery status.
What is nice about this application is having the ability to modify the status of the device.
My K400 Plus keyboard has the Function Keys and the media keys set up as such that by default, they are media keys.
This is not what I prefer so I can Swap the Fx function here.
Pairing A New Device.
My reason for using this application was to pair my new keyboard with an existing receiver.
I don’t see the value in having more than one USB port populated unnecessarily.
To Pair a new device is very straight forward, select the root “Unifying Receiver” and select “Pair”.
The dialog will pop up and ask you to turn on the device you want to pair.
When you do that, the receiver will grab the new device, associate it and have it available to be used.
That is all there is to it.
Each device will have their own set of options that are adjustable per your preferences.
This Performance MX Mouse has more options than the value M175 Mouse.
That just about does it for Solar.
There are some other fun features like getting device details but I don’t really want to post those here because I don’t really know if that is information I should be sharing.
Having Solaar in the system try is quite handy.
Though, the reality is, I don’t need it all the time but having it to manage your devices is very handy.
It’s nice to know that you can manage multiple Unifying receivers with this application.
This is easy to use and has a great, well laid out and straight forward interface.
I am glad I was recommended to try this application out.
Solaar on software.openSUSE.orgltunify Review on CubicleNate.com.
, Hardware, ,                   13 January 202013 January 2020                             Noodlings | Lighting the Emby Server with Kdenlive.
Coming back strong in 2020… no… not coming back… I haven’t been gone, just delayed.
12th Noodling, a dozen, a foot or a cup and a half of crap?.
AMD System from Yester-Years Parts.
I recently posted about my computer build.
In short, this is a computer build on parts that are in no way considered top of the line.
They are all quite old and that did pose a few problems.
One, this motherboard would not boot from a software RAID pool.
I was able to bootstrap the BTRFS RAID pool with a separate drive and root partition.
It did add some complexity to my system but I think it works out okay.
Building a system is something I have wanted to do for quite some time.
As in, several years but time, finances and decision vapor-lock had kept me from it.
What pushed me over was a fortuitous conversation at a Christmas gathering last year, I struck a nerdy conversation, with a computer store owner that ultimately gave me this giant Thermaltake case without a motherboard and a few weeks later, another fortuitous happening where I was given a bunch of old computer equipment and an AM3 motherboard was among the rest of the aged equipment which drove the rest of the build.
My course of action was to stuff the most memory and fastest processor in that which is what I did and I am happy with it.
I am not going to belabor that process as I have talked about it before and I have a link you can follow if you are interested in those details.
As a result of this, I had tons of fun, it was a great learning experience and that same guy gave me another case, not as big but far more robust in design with a water cooler.
I now want to build another machine but I am thinking a more pure gaming machine and leave this current machine to be my server workstation.
I don’t know when I would get to this but I think this one will be a project I do with my kids.
Use it as a teaching opportunity and turn it into a kind of family event.
Currently, the machine has a Core 2 Duo CPU platform of some kind.
I think I would probably do another AMD build, something newer that can take advantage of these new fancy CPUs coming out.
I still wouldn’t go bleeding edge but certainly something closer than what I have now.
Emby Server Summation.
I have fully evaluated my use of Emby and given a little write up on it.
I described the installation process, setting it up, importing my media files and so forth.
I want to just summarize the highlights and the lowlights of my experience before I begin my next testing of Plex.
What I like.
Emby is super easy to set up.
It is nothing more than copying one line into a terminal and executing it.
It is super simple and the script also seems to, at least on the version I installed, start and enable the emby-server service.
It’s super easy to add media libraries to Emby.
The wizard walks you through it in the beginning and if you want to add additional libraries, that is very easy to do through the configuration tool.
Streams to just about everything in the house.
Essentially, if it has a browser, you have access to the Emby server.
I haven’t had any issues with the system in the approximately five weeks I have been using it.
Updating the metadata and identity of any movies is as easy as a click and search.
You can change the cover images and so forth.
Some of the movies I have ripped haven’t always been detected completely correctly.
For example, there are three different Grinch movies and I had to manually define which decade they came from.
It was super easy.
The Android application works quite nicely.
I am actually impressed with the ease of use of the application.
It also has quite the fine polish to it as well.
What I don’t like.
This was an open source project that went closed source.
I sort of have an issue with that and I am not alone with that assessment.
It was at that point that Jellyfin was forked from Emby which is what makes me incredibly interested in Jellyfin.
I can’t stream to my Wii, though I don’t really blame the project for not supporting a 14 year old game console.
There isn’t an app on the Homebrew channel though at the time of writing, I realized that there is a browser on the Wii so perhaps more investigation is needed.
I will update this paragraph with any new information I learn as I investigate that possibility.
Updates will have to be done manually.
The server does say it needs to be updated and to do so requires the same step as installation.
That is really the only clunky part about this whole setup.
Final Thoughts.
Emby is pretty great.
Regardless of what I do not like about it.
It is a great experience.
If you are undecided on your media server and have a desire to try the different options, this is a good one.
If this was my only option, I could easily get along fine with it.
Since I have two others, I will check those out too.
I highly recommend you try out Emby as the shortcomings are nitpick issues.
I don’t like that it went closed source but the project, closed or open, is sound.
It is a great, well polished, experience.
This is my first media server review.
I will have follow up articles to this in the near future.
If there are any inaccuracies or areas I need to revisit, please let me know and I will take the time to make updates.
Kdenlive 19.12 Review.
It did take me a quick start tutorial to get going.
I do kind of wish there were more instructions on how to do things that weren’t in video form.
I like video and all but it is too slow to go through.
I would rather scan down a page and see little clips of how each effect is done on it’s own.
I suppose there is nothing stopping me from doing that.
Kdenlive is easy to just get going with it.
Once you understand the work flow, dump your videos, music, pictures and such in the “pot-o-media” and you are off to the races.
What I Like.
Kdenlive is incredibly stable and reliable.
Crashing is incredibly rare.
I have spent many hours at a time editing and not once has Kdenlive crashed.
In all fairness, it’s been hours of editing because I am not very good at it.
I have used and rendered video on both my Dell Latitude E6440 and my “new” AMD FX-9590 system with out any glitching or issues.

I am impressed by the stability and smooth operation of Kdenlive on openSUSE Tumbleweed

The user interface of Kdenlive makes sense.
The shortcuts, the ease of defining the effects and transition as well as previewing the video makes for an easy and enjoyable video editing experience.
Even the scrolling across the timeline or through the tracks, all just makes intuitive sense.
The options for rendering videos or even just audio has a straight forward interface that makes it quite clear what is happening when you start that render.
Also, when you start the render, you can continue to use Kdenlive.
It does not lock you out of the application.
What I Don’t Like.
The text editor for title screens is a bit ropey.
The cursor indicator isn’t always visible so I often have to make special effort to get to the right location which includes some delete and retype from time to time.
The use of it is not as much fun as the rest of the application.
Not so much a fault of the application but doing video editing really needs more screen real-estate.
One 1080p screen is not enough.
Not the fault of the application but it is hard to see and read everything going on without excessive scrolling.
Final Thoughts.
Kdenlive is a great application with a lot more features than I know how to even use.
I don’t do any complex video editing.
I don’t have good video equipment so I don’t have a real high level of motivation to create a lot of video content at this time.
You can only polish a turd so much and I am often not happy with the video I shoot.
I am happy, however, with what I can do with the video in Kdenlive.
It does make turning the lack-luster video into barely acceptable video content.
Editing with Kdenlive is easy to use and is enjoyable to turn the mess I start with into something more usable.
I would like to make more excuses to do more video content because the great user experience Kdenlive provides.
I have heard of people complain that Kdenlive isn’t stable, well, that is a bunch of hooey.

Kdenlive on openSUSE Tumbleweed works fantastically well without any crashing

I am very thankful for fantastic packaging and QA process from the openSUSE Project and I am very grateful for every programmer that has had a hand in every piece of this, from the Linux kernel to the Plasma desktop to the application itself.
Thank you for all your time and efforts.
Linux Powered Festive Lights.
Move from Christmastime to Wintertime.
One of those I like a lot more than the other but by having “winter lights” it brightens up the space around me and pushes that gray, cold, dark sadness away.
Thanks Linux.
Anything multi-colored and Christmas specific has been taken down.
The strands of multicolor lights on my porch have been replaced by blue lights.
The wreath and Santa are down but in Santa’s place is an inflatable snowman.
Everyting is now white and blue around my house.
Not as much fun as Christmastime but I think there is a rule about how much fun you can have at any point in time of the year and I don’t want to over indulge in it.
I have to keep it for the designated times, be seasonally appropriate.
I have purchased a few other little things to add to my display.
What can I say, I enjoy talking about it.
More on that in the future.
AppImageLauncher Review.
Of the three Universal package installers, AppImage is one of them.
Historically, it has been my least favorite due to the more squirrely way of managing each application.
Essentially, you had these files are scattered about your file system or shoved in a folder some place and if you wanted to put them in the menu, you had to do it manually.
When you downloaded an update, because not all AppImages support updating, you had to recreate or edit the menu entry and lacks all sense of intuitiveness.
It is just incredibly primative     Some AppImages would integrate themselves into your menu system and even perform their own updates.
Most of them, however, do not implement those nice little features.
Another step, before launching it, having to modify the properties to make it executable.
Not a difficult step but it was another step that made it feel a little clunky to use.
Combine all these anti-features together and it was my least favorite Universal package.
Sill grateful, just least interested.
Step in AppImageLauncher.
This throws a significant change in the Universal Package landscape.
I have been favoring Snaps for many reasons: the central repository, the ease-of-use in the command line or graphical tools (I used the command line), automatic updates and vast selection of applications has made it my first stop in the Universal Package route.
The next has been Flatpak.
It has a pseudo Central Repository, nothing official, it integrates nicely with Plasma’s Application Explorer, Discover.
Flatpak has recently been better about automatic updates and does a fantastic job of theming itself automatically to your desktop settings.
Lastly has been AppImages because of the rather ad-hoc nature and disjointed desktop experience they have provided.
They would respect your desktop themes and are a great non-committal way to try an application but lacked a convenient and clean way to access them.
I have used AppImageLauncher for such a short period of time but it is a game changer as far as desktop experience is concerned.
The ease of installation and removal of your application in the menu and the automatic organization makes for a purposefully integrated experience.
You really can’t tell that you are using an AppImage unless you are doing a right click in the menu entry.
Now, on my openSUSE systems, AppImage is a first-class citizen beside my system package manager (RPMs), Snaps, or Flatpak.
2020 is starting of great in the software world.
So why would you use the AUR.
BDLL Follow up.
Something that doesn’t seem to get enough attention is the BDLL Discourse Forum.
There is a lot of great discussion going on there, not just because I am dumping everything I am working on there but because it is a great place to get help, talk about your Linuxy experiences and just have great conversation about interesting things in tech.
The Linux Half Top was a thread submitted by Steve (Mowest).
He had a broken laptop screen and instead of dumping $100 plus into the machine for a new screen and touch panel, he took the screen off entirely, added an HDMI to VGA adapter.
Steve gave credit to another community member Dalton Durst for the idea.
It reminded Sleepy Eyes Vince of the Commodore 64 where the computer was in the keyboard and just needed a screen.
The whole idea was brilliant, simply brilliant and was an exercise in problem solving by looking for an entirely different solution.
Well done.
I highly recommend you take a trip to the BDLL Discourse for some very interesting discussion, discoveries and ideas.
Tumbleweed Snapshots 20191231, 20200101, and 20200103    postgresql10 (10.10 -> 10.11) 59 line item changes applied to PostgresQL    xfce4-terminal (0.8.8 -> Respect the “Working Directory” setting when opening initial window, Fix invalid geometry on Wayland, and several other polishing improvements.
xfce4-branding-openSUSE (4.14+20191207 -> 4.14+20191230) several packages relating to openSUSE branding which included setting the default cursor to Adwaita    libvirt had CVE-2019-11135 addressed    ALSA ( -> several upstream fixes and UCM and UCMv2 fixes and enhancements.
See Changes    NetworkManager (1.18.4 -> 1.22.2) Fix multiple issues in the internal DHCP client, including: wrong parsing of search domains and classless routes options, and failures in obtaining and renewing the lease with certain server configurations.
flatpak (1.4.3 -> 1.6.0) several fixes to include fixing some leaks and not to poll for updates in the portal when on a metered connection.
Catfish (1.4.11 -> 1.4.12) for Wayland and GNOME Shell support    Ffmpeg-4 numerous subpackage updates    SSHfs (3.6.0 -> 3.7.0) to give you higher max connection to improve responsiveness during large file transfers.
VIM (8.2.0000 -> 8.2.0063) 54 line item fixes    Tumbleweed Snapshot Reviewer:20191231 – moderate 7920200101 – stable 9120200103 – moderate 85    Four more snapshots are in the pipeline and at pending stable scores        I was recently watching an episode of Computer Chronicles that covered the idea of “Simulator Software” recorded in 1983.
They talked of the flight simulators of the time, simulations of architecture and urban design.
Even in the 1980s they were saving money by doing virtual testing of an environment before you spend the time and money on the real thing.
There was a flight simulator used by the military in the early 1980s that by today’s standards, not so great but if I were running that on an Amiga or x86 based PC in the mid-90s, it would have been pretty darn impressive yet.
It is interesting to see now, the graphics capabilities have advanced.
Any one modern graphics card has such incredible graphical capabilities, delivering fantastic realism.
It’s something that is pretty amazing if you stop and think about it.
I can’t help but wonder how those ideas were sold at the time to punch information into a computer that by all accounts is not all that capable of calculating the vast sets of variables that are done today.
Today, there is so much more that can be done with finite element analysis in software that you don’t have to pay for.
Examples of this are, FreeCAD and Fusion360, one an open source application, the second a close source application but free to use for hobbyists.
This is a great episode of the Computer Chronicles if you are interested in seeing the early development of computer simulation in the early 80s.
The excitement around it is pretty fascinating and we can thank these people for pushing the technology from which we enjoy the fruits today.
, , , Hardware, , , ,                   10 January 202011 January 2020          11 Minutes                    Building an AMD Server and Game Machine out of Yester-Year’s Parts.
Some time ago I started noodling around the idea of building a replacement server for my home.
I wanted to make this an extreme budget build.
I came to the realization that I have become rather disconnected with the state of desktop class video cards and really much of anything that was outside of the laptop world.
I was hung up, for quite some time on the case and motherboard selection.
I would browse Newegg and eBay but since I lacked a lot of information, I was in a constant state of decision-vapor-lock.
What changed was when I received some hardware at no cost.
An incredibly large case and an AMD motherboard locked in the portion of the project that I was unable to make any decisions and dictated the rest of the build.
So, over a period of months, I slowly acquired rest of needed components.
The case, although in good condition, certainly looks like it was at some point out moded and just became a place that parts were thrown into.
I would guess this case is as old as my Linux jouirney.
The motherboard that was given to me was an AM3/AM3+ motherboard.
I was actually kind of excited about this as I decided I was going to do a complete AMD build.
Sure, this is an older AMD CPU socket with a silkscreen date on the board of 2013 but that meant getting something  on the cheap was certain.
Also, since I don’t exactly buy new things, this fit the bill.
This is what ended up getting, mostly from eBay, so for you to replicate this selection at this price may or may not be possible.
Graphics Card Gigabyte Gammin g RX570 8GiB Graphics RAM – $89.95.
Power Supply – RaidMax RX-1000AP-S Power Supply – $74.19.
CPU – AMD FX-9590 – $119.95.
CPU Cooler – Cooler Master Hyper 212 Plus – $22.59.
Memory – 32 GiB DDR3 1866MHz – $64.95.
Storage – 6, Seagate 2TB drives – $149.70.
6-port SATA Card  – $25.35.
USB 3 All-in-one 5.25″ Front Panel Card reader – $19.99.
Blu-ray DVD player – $50.00.
2x 3.5″ to 5.25″ adapter trays – $8.58.
Serial DB9 RS232 9pin com port with bracket – $4.14.
6x SATA Cables – $9.48.
That made a grand total of $638.87 invested in this machine.
I went just a bit overbudget due to the CPU cooler.
I was warned that the TDP rating on the CPU meant it was necessary to have an effective cooler.
This was the first time I have actually assembled from parts and pieces a computer.
I have repaired and upgraded many but this was the first of this level of DIY.
Since every part I had was untested and I had no way to verify if anything was working, as in, nothing else upon which I could conduct individual component testing, there were a lot of uncertainties in this.
When I kicked it on for the first time and had everything working, I was incredibly relieved that it all worked.
There weren’t any issues at all with any of the components.
To see this machine actually start up and work in a kind of cobbled together state was not too far short of a miracle.
I was very fortunate that all the used hardware actually worked.
Operating System | openSUSE Tumbleweed.
There really wasn’t any other choice.
I need long term reliability and I am not interested in reinstalling the operating system.
I know, through personal experience, that Tumbleweed works well with server applications, is very tolerant to delayed updates and will just keep chugging away.
I have been very satisfied with the stability of Tumbleweed as a server for the last year on my “temporary system” performing that role.
The issues I did have with that system, although minor, have been with video due to the Nvidia GPU.
This build, I purposely avoided anything to do with Nvidia due to the dubious support they provide.
Storage Setup.
This was an area that took me several months of research and reading.
My criteria was that I had to have Storage Array BTRFS Raid 10.
This afforded me a lot of redundancy but also a lot of flexibility.
This will allow me to slowly upgrade my dries capacity as they begin to fail.
When deciding the file system, I did a lot of research into my options.
I talked to a lot of people.
ZFS lost consideration due to the lack of support in Linux.
I am perfectly aware that the development is done primarily within Linux now but it is not part of the mainline kernel and I do not want to risk the module breaking when the kernel updates.
So, that was a non-starter.
I looked at a few LVM options but if I wasn’t confident in understanding all the details of it and I didn’t want to risk any reliability due to my ignorance.
Why I ended up using BTRFS is due to the reliability and flexibility of the file system.
Anyone that says RAID 10 on BTRFS is not reliable is, sadly mistaken.
Since the motherboard I have wouldn’t recognize a software RAID and boot from it, I used a 7th drive to bootstrap the whole system.
That, also running BTRFS for the root file system and I threw in some Swap as well.
Used a 6-port SATA card for the 6 drives of the BTRFS RAID array and mounted it as /home.
At some point, I want to take advantage of the subvolume capabilities of BTRFS but that will come at a later time.
Additional Components.
Since this is my new central computer, as it were, I wanted this to have all the faculties for doing the regular nonsense that I conduct in my SuperCubicle.
Since it seems I have made a bit of a reputation for doing computer-y things, I tend to help other people out in data recovery, backing up their systems and so forth.
I also like to mess with Single Board Computers and although I can stick an SD Card in my laptop.
I wanted something with all the media cards in it and external SATA ports for plugging in drives as well.
This already had some USB and SATA connections on the top of the case.
The 5.25 Media Dashboard has SD, MS, MMC, XD, TF, M2, CF and SATA interfaces.
There is also a power connector port and USB3.
I have used many of these interfaces already.
As a bonus, this has a temperature sensor that I attached to the CPU cooler that tells me what the temperature of that monstrosity is.
It really hasn’t gotten real hot yet but I will see how hot I can get it after I really start pushing it.
The optical drive is also getting a regular workout as I have been dipping into the bargain bin of post-Christmas season movies to add to my media collection.
All in all, this has been the perfect hardware build for me and my purposes.
As it stands today, I only have 3 open bays on this machine so anything smaller, just wouldn’t do.
Current Activities.
I didn’t just build this system to look old in my basement.
I have had plans for this thing for longer than many of the parts.
My number one task is that this machine is my central repository of all my data.
Everything from records to movies.
To that end, outside of the standard server functions you have by “flipping a couple switches” like Secure Shell, Samba, Syncthing, I wanted to go beyond this.
Something “cool!”    Media Server.
Currently testing Emby, PLEX and Jellyfin.
This is probably what this machine does most right now.
That and ripping the DVDs and Blu-rays I purchase using MakeMKV (Another blathering for another time).
This function doesn’t seem to be very taxing on memory or processing power.
Maybe if I had more machine drawing media from it it would but that is not an issue at this time.
Gaming Rig.
Although I am not exactly doing much gaming, I think I played a game of River City Ransom: Underground with my youngest.
I have also played Descent 2 (rebirth) on this machine, and it, of course, ran it extremely fast.
At this point, I haven’t come close to taxing the video card.
I am planning to do more Linux gaming with it and by that, I mean, anything that I can run in the Linux environment, so Wine and Proton, those are also fair “game”.
Video Rendering.
Since this is the most capable machine I own, I’m using this to render video.
It does the task in 1/3rd the time of my Dell Latitude E6440.
Would faster be nicer, sure, but I don’t exactly churn out lots of video content for it to matter.
I still tend to edit the video on my laptop but render it on this machine.
Mostly because I don’t have great monitors for it yet.
That will come later.
Planned Activities.
I will be implementing a Nextcloud server and start playing around with some note taking applications that I can self-host.
Not that I am unsatisfied with Simplenote, I just happen to like to keep my options open.
Another service I want to run is Home Assistant.
I have these plans for implementing “smart devices” that are not cloud based going off someplace else.
I want to have Home Assistant, manage all my devices and make my home just a bit more convenient.
That is also another blathering for another time.
I had originally intended to make a video of the build of this, to include the installation process, but after reviewing the video and being bored out of my mind watching it, I have kicked that to the curb and will maybe turn that into an 1980s sitcom montage to music or something.
Although this computer has only been up and running for about two months, I am slowly adding more services and functions to it.
For now, it is pretty light, but in a few short months, that will most certainly start growing.
I am very happy happy with the sub-$700 build for a computer system that has met or exceeded my expectations.
It was a fun first complete, from ground up, scrap-together assembly that really was a gamble.
I am pleased with how well openSUSE Tumbleweed runs on it and that I have had no disturbances with any operating system updates.
Often, after a project, you will review it, have an “After Action Review” and ask yourself, “What would I do differently if I were doing this again.” I can honestly say, there is nothing I would change.
I like everything about this machine.
I would, perhaps, like more storage space as I have already gobbled up 2.5 TiB of my 5.5  TiB of storage space.
Reviewing what I spent and the additional cost of the larger storage, I would have still made the same decision.
So, back to would I change anything.
No, I think I made the right decision.
I do have upgrades planned for the future but that is a project for the fall.
This machine truly fits my needs, even if much of the hardware is yester-years retired bits.
BTRFS Increase RAID capacity on ServerFault.comopenSUSE.org Tumbleweed DownloadBTRFS wiki on Kernel.org5.25 Media Dashboard on Newegg.comSteam for Linux from openSUSE.org.
Hardware, , , Multimedia, , Server,                   6 January 202021 March 2020          8 Minutes                 Posts navigation.
Older posts                                                                                                          Post to              Cancel                                               Send to Email Address          Your Name       Your Email Address.


Board footer

Powered by FluxBB